Posts Tagged slow internet rtl8169

Slow internet in LinuxMint

I installed LinuxMint earlier today because I found that I really liked the Cinnamon desktop environment on my laptop. I promised that I would post how well it works on my desktop.

Well it mostly works fine. There's still a slight hiccup that I'm trying to work through, where the desktop environment just seems to die. I have this same problem on Gnome 3 and Unity though, so I think it has something to do with the ATI drivers. I wish I had a good nVidia card to go in this thing.

There's one bug that I had to post about. I was getting terrible internet speeds from my LinuxMint install. My top speed was around 190KBytes/sec. Some people may still regard this as fast, but I'm on a 30Mbit/sec connection. I should be seeing speeds around ten times that.

It was across the board too. I thought it was a bad mirror at first because I first noticed it while trying to update the system and install new software from the repos. I soon found that the problem was also happening from every web site and speedtests showed the same results.

I started out by searching for the issue and was coming up with a lot of duds. It was the standard first level support answers like "unplug your router and modem". No need, I know that's not the issue. After some intense searching, I finally found the answer. It was a problem with my network card drivers in the latest versions of Ubuntu and LinuxMint.

My system was showing a RTL8111/RTL8169 network device. The 8169 is the part to look for. This driver is built into the latest kernel and it has problems. I found that the solution was to build the r8168 drivers (note that's 8168 not 8169) from source.

A full walk-through can be found here: https://unixblogger.wordpress.com/2011/10/18/the-pain-of-an-realtek-rtl8111rtl8168-ethernet-card/

Follow those steps and you'll not have this issue again. Much thanks to the author!

, ,

No Comments